Topic: Affichage

Bonjour,

J'ai un problème au niveau de l'affichage "toujours au dessus".

A chaque lancement même l'option décochée, la fenêtre reste au dessus.

Bonne continuation

Re: Affichage

Bonjour,

Ce probleme m'a ete signale et je pensais l'avoir corrige depuis longtemps.
J'imagine que tu utilises la derniere version de MaTéléFree.
Je n'arrive pas a le reproduire que ce soit sous Windows ou GNU/Linux.
Pourrais-tu decrire une facon d'y arriver ?
Pourrais-tu aussi m'envoyer le fichier "matelefree.ini" en cliquant sur le lien "Remarques et suggestions" present dans la fenetre "A propos" du menu "?" (cela me permettra d'avoir des informations sur ton systeme) ?

Merci pour ton post,

Remi

Re: Affichage

Oui j'utilise bien la dernière version.

Par contre je suis juste un testeur et n'ai aucune compétence de programmation.

Je  t'ai envoyé le fichier matelefree.ini

Re: Affichage

Bonsoir,

J'ai essayé plusieurs fois en cochant/décochant l'option en mode fenêtré ou plein écran sans avoir le problème. J'ai fermé l'application avec ou sans l'option cochée, idem au redémarrage.

Je tourne sous Windows 10 64-bit avec mise à jour du 10/10/2017

cage

Re: Affichage

Bonjour,

Grâce à ton fichier "ini" j'ai compris le problème.

Même si ce n'est pas clairement expliqué, MaTéléFree propose deux modes d'affichage : normal et minimal.
Si le premier ne mérite pas de commentaire le second nécessite sans doute quelques explications.
Par défaut en mode minimal :
  - seule la fenêtre du lecteur vlc est affichée (arborescence listes lectures, liste lecture et barre d'outils sont cachés)
  - la taille de la fenêtre est très réduite
  - la fenêtre est placée dans l'angle supérieur droit de l'écran
  - l’icône choix du mode d'affichage est enfoncée (à gauche de l'icône "plein écran")
  - le mode d'affichage "toujours au dessus" est forcé 

Mais dans ce mode : l'affichage des sous-fenêtres (arborescence etc.) ainsi que les taille et position sont modifiables.
 
En utilisant ton fichier "ini", j'ai remarqué que l'icône "mode d'affichage minimal" était enfoncée, donc que l'affichage
minimal etait actif, donc le mode "toujours au dessus" était forcé.

Si tu changes de mode d'affichage (click sur l'icône ou Ctrl+D) tu devrais constater que le mode "toujours au dessus"
redevient ce à quoi il était supposé servir.

Donc tu avais basculé l'affichage en "minimal" sans t'en rendre compte ni prendre conscience de ce qui en découlait.
Je dois avouer que l'interface utilisateur ne t'a pas beaucoup aidée : ce n'est pas très clair.

Ce que j'envisage de faire pour le mode "minimal" :
  - Empêcher l'affichage des sous-fenêtres
  - Réduire le menu "Affichage" à une seule option : Retour au mode "normal"
 
Je pourrais éventuellement supprimer ce deuxième mode d'affichage.

J'attends toutes les suggestions possibles.

Rémi

Re: Affichage

Bonjour Rémi,

J'utilise souvent Affichage minimal que je trouve très pratique pour suivre une vidéo tout en bricolant sur le PC.
Pour le problème évoqué, lorsqu'on est en minimal et que le menu Affichage/Toujours au-dessus n'est pas coché, le fait de le cocher fait que la fenêtre minimale n'est plus au dessus.
La solution serait de cocher ce menu dès que l'on passe en minimal et de le décocher dès que l'on repasse en Affichage normal.
Il me semble qu'il serait judicieux de passer le menu Lecture/ Affichage minimal/normal dans le menu Affichage
J'en profite pour faire une demande:
Dans le mode Affichage minimal, serait-il possible de faire disparaitre la barre de menu en permettant de l'activer avec la touche Alt voire même de faire disparaitre la barre de titre pour un meilleur confort visuel.
Merci pour tout,
Gérard/cage

Re: Affichage

Bonsoir Rémi,

Effectivement je viens de voir l'astuce avec affichage normal et minimal. Il est vrai que je n'ai pas regardé plus loin que le bout de mon nez smile

Pour moi maintenant c'est parfait.

Néanmoins peut-être serait - il plus judicieux de mettre cette option dans le menu affichage.

A toi de voir wink